
Introduction to SAOImage DS9 

Setting Up DS9 

https://sites.google.com/cfa.harvard.edu/saoimageds9/download 

Visit the link noted above and download the free SAOImage DS9 application for your operating system. 
You'll find it under the "Release Version" heading near the top of the page. Mac users should download 
the appropriate "Aqua" version; Windows users should download the "Windows 64 bit" version; and 
Linux users should download the version appropriate for your build i.e.(Ubuntu, Fedora, etc.): 

Windows Installation 

The Windows download is an executable installer that will be named similar to, "SAOImageDS9 8.1 
Install .exe". Run by double-clicking the installer and allow it to place the necessary files in the default 
location. An application icon will be placed on the start menu and a shortcut will be placed on the 
Desktop. 

Mac Installation 

A disk image (.dmg) similar to the name "SAOImageDS9 8.1.dmg" is downloaded. If your browser does 
not automatically mount the image, double click on the disk image icon to mount it. Inside the disk 
image, drag the SAOImageDS9 application to the Applications folder shortcut provided inside the disk 
image. This installs DS9 in the Applications folder on your Mac and an icon will appear in the Launcher. 

Linux Installation 

The Linux download will be a gzipped tar file named similar to "ds9.ubuntu18.8.1.tar.gz". Unpacking the 
gzipped file reveals the application binary, which is named "ds9". Move the binary to a location that is 
convenient for you to access. 

Resource Images 

The images (Pluto.fit, Albireo.fit) that you'll be using for this laboratory are located in the "Resources" 
folder of the lab manual materials you downloaded from the course web page. You may also download 
the images directly using the links below: 

https://observatory.tamu.edu/courses/resources/fits/Pluto.fit 
https://observatory.tamu.edu/courses/resources/fits/Albireo.fit 
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Introduction 

In principle, cameras used to obtain astronomical images aren't that much different from the cameras in 
your smartphone in that they use either CCD or CMOS sensors. Likewise, astronomical cameras are 
readily available to the backyard astronomer in a variety of size and price ranges. 

Your phone camera can deliver your photos as a convenient graphical file type, such as a JPEG or PNG. 
These file types are good for social media or web based viewing; however, the data stored in the file for 
accessing the image is mostly color information that doesn't really tell us much about the values obtained 
by the sensor. 

The software that controls astronomical cameras stores the image data as a file in the Flexible Image 
Transport System (FITS) format. Similar to the raw format of some DSLR cameras, the FITS file retains 
the intensity values of each pixel. This is important for measuring the brightness of an object in the image. 
The FITS format also includes an extensible header that can store information about the image itself, the 
observer's location, the type of telescope, the type of camera, the size of each pixel, the object being 
imaged and its coordinates and much more. With respect to images, think of a FITS file as being more 
about the data and less about the appearance. 

Like other image file types, FITS files require specialized software for viewing the stored image and 
header information. SAOImage DS9, or simply "ds9", is a popular and very robust tool for viewing, 
managing and manipulating the data stored in the FITS file. 

It should be noted that a FITS file can store data of several forms, but the focus of this laboratory is on 
image data and to learn the basic operations of ds9 for viewing and manipulating images and regions. 

A Tour of the Application 

The general appearance of ds9 differs slightly between the operating systems. For instance, on macOS, 
the menu bar appears at the top of the desktop rather than the top of the application window. 

Once you've downloaded and installed DS9, launch it. 

Select the "File" menu and choose "Open". Navigate to and open the "Pluto.fit" image you downloaded. 
Depending on your operating system, you may also be able to double-click on the Pluto.fit file to open it 
in ds9. 

There are several panels within the ds9 application. The primary panels are: 

1. Menubar   5. Buttons 
2. Information panel  6. Display frame 
3. Panner   7. Colorbar 
4. Magnifier 
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Move the mouse pointer (don't drag!) over the image in the display frame and note the "magnifier panel" 
in the upper right corner of the application window. The "panner" just to the left of the magnifier panel 
displays the full image and the area currently viewed in the display frame. 

In the information panel, you see the file, object, value, WCS, physical, image and frame fields. As you 
move the mouse pointer, the WCS field displays the equatorial coordinates under the tip of the mouse 
pointer. WCS stands for "World Coordinate System"and refers to the coordinate system mapped to the 
FITS file. Not all FITS images include a WCS. This is something that is typically mapped after the image 
was obtained using software other than the camera control software. 

3



Just above the image panel is the "buttons" panel. A number of menu options can be managed from the 
buttons for convenience. Press the "zoom" button and then press the "zoom fit" button. This allows you to 
view the entire image within the confines of the display frame. 

DS9 does not have a scrolling option for moving the image around in the display frame. However, there 
are a couple of ways to pan. First, use the buttons to "zoom in". Notice how the panner changes. Click-
and-drag the inset in the panner to move the image in the display frame. 

The other way is to use the "pan" mouse option. Select the "Edit" menu (or button) and choose the "pan" 
option. The point in the image display frame that you click will be centered in the frame. To re-center the 
image, select "Zoom" from the menubar and choose "Center Image". 

Adjusting the Image Scale 

The scale of the image refers to the balance much like you would adjust the white balance or background 
of a black & white photograph. You may know some these functions by the terms level or brightness and 
contrast. 

Select the "Scale" menu and choose "98%". If you want to adjust the scale manually, select the "Scale" 
menu and choose "Scale Parameters...". The dialog box that appears displays a histogram of the image 
along with a red and green marker. Dragging the markers changes the scale of the image. You can reset 
the scale by selecting "98%" from the "Scale" menu. 

Using Regions 

Regions in ds9 allow you to isolate specific astronomical targets within an image. Regions can also be 
saved in a separate file for future reference. One use for regions is to determine or mark the position of a 
target. Pluto is hiding somewhere in the image. You'll create a region and edit the equatorial position to 
find it. 

Select the "Edit" menu and choose "Region". 

Select the "Region" menu and choose "Shape > Circle". 
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Click anywhere on the image. A green circle should appear. 

Click inside the region to select it. Drag handles should appear, which can be used for adjusting the 
diameter of the region. Note that when a region is selected, pressing the delete key on your keyboard will 
remove it. 

With the region selected, go back to the "Region" menu and choose "Get Information...". The 
information dialog box appears. Note: ds9 responds to mouse movement over the application window. If 
the information dialog disappears, it's likely hiding behind the application window. Double-clicking 
inside the region will bring it forward again and you can move it so it doesn't keep hiding itself. 

In the information dialog, locate the "Center" label. The text field on the left is the right ascension and the 
field on the right is declination. Edit these fields to reflect the equatorial coordinates for Pluto at the time 
the image was taken (RA 19:13:26.9  DEC -21:39:34.0), click the "Apply" button and then close the 
dialog. Pluto should now be centered in the region. 

Using the buttons above the display frame, save the region by selecting the "region" button and then the 
"save" button. Select a save location, enter a name and choose "Save". The "Save Regions" dialog 
appears. The "Format" should be set to "ds9" and the "Coordinate System" should be set to "fk5". Choose 
"OK" to save the region file. 

Measuring Angular Distance 

There are times when it's necessary to measure the pixel distance or the angular distance between two 
objects in an image. If the FITS image includes a WCS, you can measure both pixel distance and angular 
distance. If the image does not include a WCS, you'll only be able to measure pixel distance. 

5



First, remove any existing regions by selecting the "region" button; then the "all" button; and finally the 
"delete" button. Of course, you can select each region individually and press the delete key on your 
keyboard. 

Next, open the "Region" menu and choose "Shape > Ruler". 

On any part of the image visible in the display frame, click & drag to create the ruler region. 

Click anywhere inside the ruler you just created to select it. This makes the control handles appear. 

Using the control handle at the tip of either arrow, drag to change the position of the ruler. Measure the 
angular distance between a couple of stars or a star and Pluto. 

By default, the ruler measures in degrees. To change the scale of the ruler, show the information dialog. 
This can be done by selecting the "region" button and then the "information" button. In the information 
dialog on the same line as the Length label, change degrees to arcsec or arcmin. 

It should be noted that the angular distance between two objects, often stars, can also be referred to as 
angular separation. In this sense, it is used to clarify that the angular measurement is observed from Earth. 
This is common practice for measuring the separation between two stars in a binary star system. 

Close the information dialog and remove the ruler region. 

Displaying the FITS Header 

FITS files contain a header that can provide detailed information about the data stored; the universal date 
and time of the exposure start; the observing location; the observed object; the camera and telescope; and 
much more. To view the header, select the "File" menu and choose "Display Header...". Alternatively, 
you can also select the "file" button and the "header" button from the buttons panel. 

Each line in the header is a "card image", which contains three components: keyword, value, comment 
taking the form: keyword = value /comment. For example, the following card image notes the universal 
date (UTC) for the start of the exposure 

DATE-OBS= '2017-08-17T03:26:44.649' / SBIGFITSEXT UTC of start exp. in ISO 8601 

Converting to a Graphics Format 

If you want to display a FITS image on a web page, or share it with family and friends, you'll need to 
convert it to a graphics format. The choices offered by ds9 are GIF, TIFF, JPEG and PNG. There are two 
options under the "File" menu for converting: Export and Save Image. 

6



The "Save Image" option saves only the area of the image visible in the display frame at the zoom level 
you have selected. It also saves the colorbar, which is at the bottom of the application window, with the 
image. 

If you want to save the entire image without the colorbar, choose the "Export" option. If you've changed 
any of the scale parameters to make the image look more aesthetic, this option preserves those parameters 
in the final graphics format. 

Whichever method you choose, select the appropriate graphics format and follow the on-screen dialogs to 
save the converted image. 

7


